+ Reply to Thread
Results 1 to 5 of 5

Java Oracle OCI Driver compatible for 9i and 10g

  1. Java Oracle OCI Driver compatible for 9i and 10g

    All,
    I have an web based Java application deployed in Tomcat 5.5.9 using
    JDK version 1.5 on windows.we use oracleOCI client to connect to
    oracle database.

    earlier we were using 9i version classes12.jar to connect to 9i
    database using 9i client.Now as we are upgrading our applications to
    use oracle 10g. Also as we still need to support oracle 9i, how can i
    make my application support both of them.

    If i use the 10g library classes12.jar in my application, i am not
    able to connect using 9i client to 9i database and vice versa.

    Even using 10g client's ojdbc14.jar i was not able to connect to db
    using 9i client.

    Please suggest.


  2. Re: Java Oracle OCI Driver compatible for 9i and 10g

    On Mar 15, 1:21 pm, prashde...@gmail.com wrote:
    > All,
    > I have an web based Java application deployed in Tomcat 5.5.9 using
    > JDK version 1.5 on windows.we use oracleOCI client to connect to
    > oracle database.
    >
    > earlier we were using 9i version classes12.jar to connect to 9i
    > database using 9i client.Now as we are upgrading our applications to
    > use oracle 10g. Also as we still need to support oracle 9i, how can i
    > make my application support both of them.
    >
    > If i use the 10g library classes12.jar in my application, i am not
    > able to connect using 9i client to 9i database and vice versa.
    >
    > Even using 10g client's ojdbc14.jar i was not able to connect to db
    > using 9i client.
    >
    > Please suggest.


    i think that classes12.jar are jdbc drivers for java 1.2, for java 1.4
    and above you must use ojdbc14.jar.
    In the name of the jar file there is not the Oracle version. I use
    drivers of 10g to connect to 9i without any problem.
    See the oracle documentation, i believe that oracle certifies
    compatibility of 10g drivers with 9i (release 2, because
    previous release are not supported)


  3. Re: Java Oracle OCI Driver compatible for 9i and 10g

    On Mar 15, 8:29 pm, "Cristian Cudizio"
    wrote:
    > On Mar 15, 1:21 pm, prashde...@gmail.com wrote:
    >
    >
    >
    >
    >
    > > All,
    > > I have an web based Java application deployed in Tomcat 5.5.9 using
    > > JDK version 1.5 on windows.we use oracleOCI client to connect to
    > > oracle database.

    >
    > > earlier we were using 9i version classes12.jar to connect to 9i
    > > database using 9i client.Now as we are upgrading our applications to
    > > use oracle 10g. Also as we still need to support oracle 9i, how can i
    > > make my application support both of them.

    >
    > > If i use the 10g library classes12.jar in my application, i am not
    > > able to connect using 9i client to 9i database and vice versa.

    >
    > > Even using 10g client's ojdbc14.jar i was not able to connect to db
    > > using 9i client.

    >
    > > Please suggest.

    >
    > i think that classes12.jar are jdbc drivers for java 1.2, for java 1.4
    > and above you must use ojdbc14.jar.
    > In the name of the jar file there is not the Oracle version. I use
    > drivers of 10g to connect to 9i without any problem.
    > See the oracle documentation, i believe that oracle certifies
    > compatibility of 10g drivers with 9i (release 2, because
    > previous release are not supported)- Hide quoted text -
    >
    > - Show quoted text -


    Thanks for your reply cristian.
    When you tell "you were able to connect using drivers of 10g to
    connect to 9i " did you use the OCI drivers and what version of
    orackle client was used, 9i client or 10g client.


  4. Re: Java Oracle OCI Driver compatible for 9i and 10g

    On Mar 16, 6:10 am, prashde...@gmail.com wrote:
    > On Mar 15, 8:29 pm, "Cristian Cudizio"
    > wrote:
    >
    >
    >
    > > On Mar 15, 1:21 pm, prashde...@gmail.com wrote:

    >
    > > > All,
    > > > I have an web based Java application deployed in Tomcat 5.5.9 using
    > > > JDK version 1.5 on windows.we use oracleOCI client to connect to
    > > > oracle database.

    >
    > > > earlier we were using 9i version classes12.jar to connect to 9i
    > > > database using 9i client.Now as we are upgrading our applications to
    > > > use oracle 10g. Also as we still need to support oracle 9i, how can i
    > > > make my application support both of them.

    >
    > > > If i use the 10g library classes12.jar in my application, i am not
    > > > able to connect using 9i client to 9i database and vice versa.

    >
    > > > Even using 10g client's ojdbc14.jar i was not able to connect to db
    > > > using 9i client.

    >
    > > > Please suggest.

    >
    > > i think that classes12.jar are jdbc drivers for java 1.2, for java 1.4
    > > and above you must use ojdbc14.jar.
    > > In the name of the jar file there is not the Oracle version. I use
    > > drivers of 10g to connect to 9i without any problem.
    > > See the oracle documentation, i believe that oracle certifies
    > > compatibility of 10g drivers with 9i (release 2, because
    > > previous release are not supported)- Hide quoted text -

    >
    > > - Show quoted text -

    >
    > Thanks for your reply cristian.
    > When you tell "you were able to connect using drivers of 10g to
    > connect to 9i " did you use the OCI drivers and what version of
    > orackle client was used, 9i client or 10g client.


    We use JDCB THIN drivers. I can't understand what do you mean with
    client version.
    If you user jdbc thin client you don't need any other client, if you
    use oci you can use
    instant client that must be same version of jdbc driver library. I use
    also sqlplus 10.2 to connect
    to our 9iR2 databaseses


  5. Re: Java Oracle OCI Driver compatible for 9i and 10g

    Oracle drivers are backward compatible but not forward compatible.

    So, you should be able to use the 10 driver to connect to both 10 and
    9 databases.


+ Reply to Thread